ZBrush 髪の毛を作った日

今日は一日かけて髪の毛を作っておりました。
時間が掛かったのは単純にZBrushの知識&熟練度不足なのと、事前に用意していたキャラデザの髪があまり立体的に考えられておらず、試行錯誤が必要だったため。立体意識がまだまだ足りない…!
まだこれで決定とするには不安があるので、他の3D作品やフィギュアなどを参考にブラッシュアップしていく予定です。

ZBrushで髪を作る方法はこちらの動画を参考にさせて頂きました。
これを見る途中までかなり非効率的なやり方で作業していたので、適切な機能とアプローチを知ることは大切だなぁと再認識しました。おしまい。

ZBrush キャラクターモデル進捗

少しずつ進んでいるオリジナルの3Dキャラモデリング。
前回のふわっとした記事から作業も進んで、作りたいキャラのデザイン+それを反映したイラストが完成しました。

で、現在はZBrushで素体の作成を行っております。
過去数回の挫折を振り返ってみると、その原因は顔の造形などが定まらないままローポリ作業に手を付けたことにありました。頂点をチマチマ移動させての試行錯誤に時間が掛かり、途中で心が折れてしまったのです。

なので今回はその反省を踏まえ、造形に集中して試行錯誤できるZBrushで事前にイメージを固めてから次の作業に移ることにしました。具体的には髪型を含む頭部の形状と、頭身のさじ加減などですね。あと一部服装のデザインも。
それでもやはり頭部は作るのに苦労して時間が掛かりました。なんとか形にはなったと思うのですが、実際に目や口が入るとまた印象が変わりそうで怖い…

とりあえず今日で体全体は完成したので、明日からはうっかり忘れていた耳と髪の作成に入ろうと思います。
服についてはZBrushで作るのはちょっと大変そうなので、そちらはBlender側で確認作業をする予定。
とにかく無事に最後まで完成させたい…!うまくいくことを願いつつ、今日はこの辺で。それではまた明日。

トゥーンレンダリングの試運転デース

3Dモデル作る前に陰影とかをどうするか決めねば…ってことで昨日はUnityのトゥーンレンダリングについて調べておりました。
といっても検索をかけたら上位にユニティちゃんトゥーンシェーダーなるものがあったのでこれを試しただけです。安心と信頼のユニティちゃん。
テスト用モデルには鳴花ヒメの3Dモデルをお借りしました。前にCG Worldを読んだ時にダウンロードしておいたやつ。つまりは借り物&借り物によるテストなので今回は画像なし。

解説サイトを読みつつ設定してみるとモデル全体が明るく表示され、影もシンプルに落ちて非常に良い感じでした。影の境界も任意にぼかすことが出来るので、個人的に好きじゃないジャギジャギ感を回避できるのも嬉しい。
今回は基本的な項目しか確認していないので、次は他の設定項目やシェーダーを試してみる予定です。平行してトゥーンレンダリングのお勉強も…ベースカラー以外のテクスチャの適切な作成&設定方法を知っておきたい。

そんな感じでスローペースで進行しております。6月中にモデルを完成させたいな…!

そうさゼロパーセント透明感

3Dモデルのキャラデザ模索中。

衣服の装飾に宝石を使いたいのですが、ローポリだと宝石の表現どうすんだ…ってことで試しにiPadで描いた宝石っぽいやつをそのまま雑に貼ってみる。うーん。
テクスチャが左右対称だったりハイライトの主張が強かったり、3D側もライティングとか一切いじらずにプレビュー出してるとはいえ、テクスチャに描き込む方式で宝石や水晶の透明感を表現するのはちょっと厳しいかなぁ。

引きの絵や細かいパーツならこれでも大丈夫そうですが、今回はローポリ~ミドルポリくらいの、カメラの位置を問わず全体的に破綻なく見えるものを作りたいので…ちょっと他の表現方法を考えようと思います。
ついでにハイライトや陰影の表現方法についても調べておかねば…とにかく知識と情報と経験と速さが足りない…!

ただまぁ特定のソフトのマテリアルに依存したり…というのはちょっとイヤなので、難しいようなら宝石は諦めて他のものをデザインに用いることも考えています。出来れば単品でそこそこ完結したモデルを作れるといいなぁと。
今まで何度かキャラクターモデリングをやろうとして途中で投げてきたので、今回こそは完成させたいですね。いや完成させよう。完成させて自分への報酬としてVR機器を買おう。そうしよう。

ZBrush 何故か投影が成功しなかった話

大分間が空いてしまい、久々のZBrush記事になってしまいました。
これまでの経緯を整理すると「ZBrushで動物を制作→Blenderでリトポロジー→ZBrushに戻して投影→入り組んだ部分を中心に超ジャギる&他の場所も全く投影されず…」という状況でした。
設定値をいじったりローポリに手を加えたりしたものの効果も無く、仕方ないので一旦これは置いておいて、ZBrush側のリメッシュも試してみようか、というのが前回の終わり。

で、昨日ようやく重い腰を上げてZBrush側でリメッシュを掛けて(なんなら密度指定や辺の流れも調節して)、投影を行ってみました。が、これもダメ。前回同様耳のあたりでポリゴンがゲッダンする。
ただ前回と違ってモデル間にそこまで形状の差異は無いはず。にも関わらずエラーが起きるということは、元のモデルに問題があるのでは…?ということでもう少し頑張って調べてみることに。

まずはポリゴンのゴミ的なものが紛れていないかのチェックから。ダイナメッシュでゴリゴリやっていたので知らず識らずのうちに内側とかにポリゴンが出来たのかも…
ポリグループの自動グループ機能で組分けしてサブツールでグループ分割を掛ける。結果、ゴミポリゴンは見つからず。

次にモデル全体のスケールを調整。プリセットの球と比べてかなり大きかったので小さめにしてみました。
結果、改善したような気もするけどまだ全然ジャギる。

早くも心当たりが無くなり、元のモデルにもリメッシュを掛けて投影、効果なし。
複製してリメッシュを掛けたモデルを投影先にする。投影成功。あれ…?
もしやと思い元のモデルをそのまま複製して投影先にする。投影成功。なんで?

そのまま複製して成功するならサブツールの設定に問題があるはず…とリストを眺めて初めて気付きました。

サブツールのアイコン郡、投影に失敗するモデルだけ別のやつになってる…

公式リファレンスによるとリメッシュの追加や減算に関わる設定のようで、試しにデフォルトの追加に戻したらあっさり投影に成功しました。どうやら気づかないうちにアイコンを押してしまっていたらしく、これが投影に影響を与えていたようです。あー、機能とかちゃんと知っておかないからこうなるー…

この後Blenderでリトポロジーしたモデルもうまく投影できたので、ZBrushとの比較記事をと考えていましたが、もう長いのでそれはまた次回にでも書こうと思います。
ともあれこれでようやくUV展開や色、質感に進めます。既に燃え尽きた感が凄まじいけれど…